Symptoms

When restoring a package to a target site – the import / restore stops with this runtime error:

Unable to rename tables, please check that your database is not empty or these tables exists

Causes

Based on previous cases – this is usually caused by some customized database configuration in your source site. It creates an incorrect database / incompatible dump to your target database. As a result – you will get this error when doing an import.

Solution

The most recommended solution is to re-create the export package using the latest version of the Prime Mover plugin. This will ensure the exported package is correct and includes the fix to handle this error.

In detailed steps:

  • In your source site (where you create the package) – make sure you are using the latest Prime Mover version. As of June 2024 – this should be Prime Mover 1.9.9 + / Prime Mover PRO 1.9.9 +. If you are using an old version – deactivate and uninstall/delete the version. Please download the latest version from the WordPress.org repository (for FREE version users) or inside your Freemius account for PRO / Trial users.
  • Now you are using the latest version of Prime Mover, re-generate the export to your target site. If you are using PRO version – don’t check the encryption setting in the export. This will disable encryption for the package which will make troubleshooting easier later on.
  • In your target site (where you want to restore the package) – make sure also that you are using the same latest version of the Prime Mover plugin.
  • Finally, restore the package and you should not see this error.

Help! I am still getting the error

If you are still getting the error after following the above troubleshooting steps – you need to escalate this to technical support for analysis and investigation. Please send us an email directly to our technical support by using the official contact form. Please include the following required information in your message:

  • Link to download the WPRIME package. You can upload this temporarily to Google Drive or DropBox and share it with us. You can delete it after we already downloaded it.
  • Name of your source site and target site hosting company (where you create and restore the package). We need this information so we run tests for hosting compatibility.
  • Link to download the runtime error log. This is the error log generated when you attempted to restore the package in your target site. For convenience (especially if this is large) – you can zip it and send us a link to download it in your email.
  • In your source site (where you create the package) – Go to Prime Mover -> Advanced -> Advanced Settings Panel -> Debugging Tools -> Download log and click “Download log file“. This will download the complete migration export log.
  • In your source site (where you create the package) – Go to Prime Mover -> Advanced -> Advanced Settings Panel -> Upload/Download Parameters -> Export site info and click “Export site info“. This will download your source site info details including your Prime Mover settings data. This is your site information log.
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